Back to overview
Degraded
Services Migration
Mar 29 at 05:46pm CST
Affected services
New York
New York Gaming
Billing
Gaming Panel
Resolved
May 06 at 02:17am CST
Gaming Panel is now up again, stay tuned to purchase these services again
Affected services
Gaming Panel
New York Gaming
Updated
Apr 06 at 09:35pm CST
We are almost finished with the migration of some services. Some services will be degraded during this transition.
Affected services
New York
Billing
Gaming Panel
Created
Mar 29 at 05:46pm CST
We are currently doing some migrations to all our services, some services such as VPS, Gaming Host and Web Hosting could become unavailable. Dedicated servers aren't affected
Affected services
New York
Billing
Gaming Panel