Back to overview
Resolved
Scheduled Network Infrastructure Maintenance
Aug 21, 2026 at 4:00am UTC
–
Aug 21, 2026 at 6:00am UTC
Affected services
New York
New York Gaming
Gaming Panel
Dedicated Panel
Resolved
Aug 21, 2026 at 6:00am UTC
Maintenance ended
Affected services
Created
Aug 21, 2026 at 4:00am UTC
We will be performing scheduled network infrastructure maintenance to upgrade core router software and improve system stability.
Expected Impact: Brief intermittent connectivity or potential downtime during this 3-hour window.
Affected services