Back to overview
Resolved

Scheduled Network Infrastructure Maintenance

Aug 3, 2026 at 10:40pm UTC  –  Aug 3, 2026 at 11:21pm UTC
Affected services
New York
New York Gaming
Gaming Panel

Resolved
Aug 3, 2026 at 11:21pm UTC

The scheduled maintenance has been completed. Thank you for your patience!

Updated
Aug 3, 2026 at 11:21pm UTC

Maintenance ended

Created
Aug 3, 2026 at 10:40pm UTC

We are conducting preemptive maintenance on one of our nodes to ensure security updates are applied correctly. As a result, some services may experience temporary downtime.